FlawOpen

flawopen.com/Incidents/ahsaycbs-auth-bypass-command-injection-october-2026

● Ahsay · CVE-2026-105133 · 2026-10-07 · CVSS 10.0 · Critical
FlawOpen Security Research

AhsayCBS: Authentication Bypass Chained to Command Injection

As of 2026-10-12, Huntress reports AhsayCBS through 10.3.4 affected and observed attacks beginning October 7. Ahsay now says earlier fixes 10.3.4.0 and 9.15.2.59 did not fully address both flaws; it directs v10 partners to hotfix 10.3.4.45 and v7–v9 partners to 9.15.2.70, followed by a reboot. The partner-only hotfix details were not independently reviewed, so confirm the installed build and follow Ahsay’s current instructions.[1], [8], [3], [4]

💡 Plain English Explainer (ELI5)

Imagine a visitor slipping past the backup-room identity check, then writing a note for the operator. The receiver endpoint treated attacker-controlled input as part of an operating-system command, so the note could be interpreted as an instruction instead of data. The analogy describes Huntress's reported chain; the exact Ahsay implementation is not public.[1], [3], [4]

Core Concepts & Subsystem Terms

CVE-2026-105133
A medium-severity improper-authentication flaw reported in AhsayCBS's checkSysPwd function. Huntress describes it as the first step in the observed chain.[3], [1]
CVE-2026-105134
A Critical, CVSS 10.0 OS command-injection flaw reported in the Replication Receiver API at /rps/api/json/UpdateReceivers.do. Huntress says it enabled code execution after the authentication bypass. The 10.0 score applies to this CVE, not both flaws.[4], [1]
Patch status as of 12 October 2026
The CVE records initially listed 10.3.4 as fixed, and Huntress later found versions through 10.3.4 affected. Ahsay's October 10 and October 12 announcements supersede its October 9 position: earlier fixes 10.3.4.0 and 9.15.2.59 did not fully address both flaws. Ahsay directs v10 partners to 10.3.4.45 and v7–v9 partners to 9.15.2.70, followed by a reboot. These are vendor instructions; partner-only hotfix contents and effectiveness were not independently reviewed.[1], [8], [3], [4]

Framework mappings

  • CWE reference for the weakness described in this guide: CWE-78 CWE-287

Version status and defensive action

Evidence sourceWhat it saysOperator decision
CVE records (4 Oct)Initially list 10.3.4 as fixed for the two CVEs.Treat this as disputed; verify the fix directly with Ahsay before closing remediation.
Huntress (8 Oct)Reports exploitation and says versions through 10.3.4 were also affected.Treat systems through 10.3.4 as potentially affected; restrict management access and investigate.
Ahsay v10.3.4 release notes (5 Aug)Name neither CVE or a security fix for either flaw.Do not infer that 10.3.4 fixed these CVEs from the release notes alone.
Ahsay v10.3.2 release notes (20 Jul)List a generic “Ahsay Security Patchset - 2026/Q3” but do not identify these CVEs or a fixed version.Do not treat the generic patchset label as proof these CVEs are fixed. Huntress later reported v10.3.4 affected.
Suspected compromise at any versionA version number does not rule out earlier exploitation or persistence.Investigate the host, preserve evidence, assess backup integrity, and use trusted recovery procedures.
Ahsay announcements (10 and 12 Oct)Earlier fixes 10.3.4.0 and 9.15.2.59 did not fully address both flaws. Ahsay directs v10 partners to 10.3.4.45 and v7–v9 partners to 9.15.2.70, then reboot.Follow the version-specific vendor instruction, reboot, and verify the installed build through the partner channel; the hotfix contents were not independently inspected.

Incident Timeline

2026-10-04

CVE records for the two AhsayCBS flaws were published and initially listed 10.3.4 as fixed.[3], [4]

2026-10-07 23:20:15 UTC

Huntress began observing exploitation of the flaws against exposed systems.[1]

2026-10-08

Huntress reported five organizations targeted and corrected its earlier version assessment: it found 10.3.4 affected too.[1]

2026-10-09

As of publication on October 9, no vendor-confirmed fixed version had been identified.[5]

2026-10-10

Ahsay announced that v10.3.4.0 did not fully address both flaws and directed v10 partners to hotfix 10.3.4.45.[8]

2026-10-12

Ahsay updated its guidance: v10 partners should apply 10.3.4.45; v7–v9 partners should apply 9.15.2.70. Reboot after either hotfix.[8]

Step-by-Step Attack Flow

Step 1

An exposed management interface is reachable

Huntress says the observed activity targeted internet-accessible AhsayCBS web interfaces. It reported that the product is used by managed service providers and system integrators.[1]

Step 2

The authentication boundary is bypassed

Huntress attributes the first stage to CVE-2026-105133 and the checkSysPwd function in ApiStructsAction.java. This is the responder's description; public vendor source for the vulnerable implementation was not available in the reviewed material.[1], [3]

Step 3

The Replication Receiver flaw provides code execution

Huntress links CVE-2026-105134 to command injection in /rps/api/json/UpdateReceivers.do. It reports attackers configured a receiver and placed JSP webshells in the application's served directory. No request syntax or payload is reproduced here.[1], [4]

Step 4

Respond as a possible host compromise

Huntress observed service-process activity followed by webshells, disguised mining software, and persistence in affected cases. Restrict management access, investigate the host and backups, and use trusted rebuild guidance if compromise is confirmed.[1], [6]

Source Code: Flaw vs. Secure Implementation

The secure example uses a fixed executable, an explicit allowlist, and separate ProcessBuilder arguments; it does not invoke a shell or concatenate user input into a command string. This is a generic defensive pattern showing how to close the OS-command parsing boundary, not Ahsay source or its patch. The public sources reviewed do not expose the vendor implementation or fix.[1], [3], [4]

UNPATCHED FLAW
// Generic anti-pattern only; not Ahsay source.
void updateReceiver(Request request) {
    String receiver = request.parameter("receiver");
    String command = commandBuilder.forReceiverUpdate(receiver);
    operatingSystem.execute(command); // unsafe command-string boundary
}
HARDENED SECURE PATCH
// Generic defensive design only; not an Ahsay patch.
private static final Set<String> ALLOWED_RECEIVERS = Set.of("primary", "archive");

void updateReceiver(Principal principal, ReceiverInput input) throws IOException {
    authorization.require(principal, Permission.MANAGE_RECEIVERS);
    String receiver = input.receiverId();
    if (!ALLOWED_RECEIVERS.contains(receiver)) {
        throw new IllegalArgumentException("Unsupported receiver");
    }
    new ProcessBuilder("/usr/local/bin/replication-tool", "update", "--receiver", receiver)
        .start(); // fixed executable; separate arguments; no shell
}

Engineering & System Hardening Checklist

Sources